PHP is amongst the most commonly used programming languages. It is highly popular since it’s free software, which can be used to build responsive sites like social networking websites, e-shops or online teaching sites rather than static HTML sites. A PHP module must be present on the web server where a PHP-powered website is hosted so that its source code can be read. Since there are no license charges for this type of module and the language itself provides countless possibilities for the web applications that you develop, there are hundreds of millions of PHP sites. What is more, there’re many PHP-based scripts, which you can use for your sites without the need to have any programming experience. Given the fact that there are a handful of versions of PHP, you ought to verify whether the very same version that you used while building your website is activated on the server as well.

PHP 4 and PHP 5 Support in Cloud Hosting

Our cloud hosting servers support different PHP versions, which means that your websites will run correctly even if your PHP scripts are out of date. We accept the fact that an old website does not necessarily suggest an insecure one as you may have implemented plenty of code modifications. That is why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can choose which version will be active for your shared web hosting account. You can change the version with one single mouse click inside your Hepsia hosting Control Panel and the new settings will take effect straight away. In case you wish to run both older and newer scripts, there is even an option to use a different PHP version for each domain name of yours simultaneously.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

We’re unswerving in our conviction that several years spent setting up a site should not be lost, which implies that in case you get a semi-dedicated server from our company, you’ll be able to run any script, be it old or new. Unlike lots of web hosting companies, we support several different versions of PHP on our avant-garde cloud web hosting platform – 4, 5.2, 5.3, 5.4 and 5.5. You will not only have the ability to enable the required version from your Hepsia Control Panel, but you will also have the possibility to specify a different version for each website. The latter can be done merely by putting an .htaccess file within the root directory of the given site. You can change the current version not only for a single site, but also for the whole account and the new settings will take effect in just several minutes. With our hosting services, you can be sure that you will never come across any website compatibility problems.